XAMPPとMovableType

Facebooktwittergoogle_plus

XAMPPとMovableType(以下MT)を今度買ったノートPCに入れようとしたらMTがうまく動かなかったので、その備忘録。

【つまづいたところ】
(1) 最初XAMPPは最新のXAMPP 1.7.0を入れ、それのアドオンであるPerl 5.10.0-2.2.11をインストールしたが、mt-check.cgiがサーバエラーで動かない。

これは、http.conf#ScriptInterpreterSourceのコメントアウトを外して解消しました。

(2) mt-check.cgiが見れるようになってもDB関係のPerlモジュールが認識されていない。
(3) そのため、Perlモジュールを入れようとしたが、ppmが入っていないので、モジュールを入れられない。どうやらアドオンのPerl 5.10系ではppmが同梱されていないらしい。
(LinuxならまだしもWindows上で自力でがんばってモジュールをコンパイルするほどXAMPP+MTの環境が必要なわけでもない)

ググッてこういう方とか、こういう方、他にこういう方などの(多少情報は古くなってるが)いろいろなブログを総合したところ、古いバージョンで問題は起きていないようなので、ダウングレードをしてみる。
結果、以下のバージョンまで下げれば問題なく動くのが確認できました。
xampp-win32-1.6.8-installer.exe
xampp-win32-perl-addon-5.8.8-2.2.8-installer.exe